Tuesday, 4 October 2011

The First Tablet Built For Business


The First Tablet Built For Business



EDGE And GPRS

Edge vs GPRS

EDGE or Enhanced Data Rates for GSM Evolution is a digital mobile phone technology attuned backwards. This technology, also termed as Enhanced GPRS or Enhanced Data rates for Global Evolution or IMT Single Carrier makes superior data transmission rates possible. This happens as an extension adding to the standard GSM technology. It is a 3G Radio technology and also belongs to the 3G definition owned by the ITU. On the other hand GPRS or General Packet Radio Service is a mobile data service that is essentially packet oriented. This technology can be availed by users opting to the 2G and 3G communication systems of the global system for mobile communications or GSM.

Given the recent technological updates it has become more than obvious that EDGE is a technology which is not just going to bring it hard on the GPRS technology but surpass it as well. This is precisely so because EDGE gives the users the inimitable chance to increase the throughput capacity and the data speed at least 3 to 4 times higher to what GPRS offers.

Moreover, EDGE also allows the existing TDMA and GSM carriers to provide the much needed and sophisticated 3G services. EDGE provides a single symbol for each 3 bits. So there itself what becomes evident is the EDGE rate is single handedly 3 times that of the GPRS rate. It has a higher bit rate precisely because the technology is based on a modulation structure of 8PSK. Hence the bit rate improves over the air Interface. As the very name suggests, EDGE is the enhanced and upgraded form of GPRS surpassing it in a number of technical aspects.

GPRS is unable to allow the service providers and operators to have an access to extended wireless data application which is otherwise possible with the use of EDGE. With EDGE it is possible to access web based email, wireless multimedia, the upgraded technology of video conferencing which is a ground breaking procedure, and not to forget web based infotainment as well. GPRS is unable to offer the entire assortment. Further more the evolved form of EDGE exists with Release 7 as well of the 3GP standard, provides decreased latency and a performance level that is two times higher than the prior form.

Summary:
 1. EDGE stands for Enhanced Data Rates for GSM Evolution whereas GPRS stands for General Packet Radio Service.
 2. EDGE is a digital mobile phone technology but GPRS is a mobile data service.
 3. EDGE allows existing TDMA and GSM carriers to provide 3G services whereas GPRS allows both 2G and 3G communication systems.

Routing Information Protocol RIP


Routing Information Protocol (RIP) is a standards-based, distance-vector, interior gateway protocol (IGP) used by routers to exchange routing information. RIP uses hop count to determine the best path between two locations. Hop count is the number of routers the packet must go through till it reaches the destination network. The maximum allowable number of hops a packet can traverse in an IP network implementing RIP is 15 hops.
it has a maximum allowable hop count of 15 by default, meaning that 16 is deemed unreachable. RIP works well in small networks, but it's inefficient on large networks with slow WAN links or on networks with a large number of routers installed.
In a RIP network, each router broadcasts its entire RIP table to its neighboring routers every 30 seconds. When a router receives a neighbor's RIP table, it uses the information provided to update its own routing table and then sends the updated table to its neighbors.

Differences between RIPv1 or RIPv2

RIPv1

  • A classful protocol, broadcasts updates every 30 seconds, hold-down period 180 seconds. Hop count is metric (Maximum 15).
  • RIP supports up to six equal-cost paths to a single destination, where all six paths can be placed in the routing table and the router can load-balance across them. The default is actually four paths, but this can be increased up to a maximum of six. Remember that an equal-cost path is where the hop count value is the same. RIP will not load-balance across unequal-cost paths

RIPv2

  • RIPv2 uses multicasts, version 1 use broadcasts,
  • RIPv2 supports triggered updates—when a change occurs, a RIPv2 router will immediately propagate its routing information to its connected neighbors.
  • RIPv2 is a classless protocol. RIPv2 supports variable-length subnet masking (VLSM)
  • RIPv2 supports authentication. You can restrict what routers you want to participate in RIPv2. This is accomplished using a hashed password value.

RIP Timers

RIP uses four different kinds of timers to regulate its performance:

Route update timer

Sets the interval (typically 30 seconds) between periodic routing updates in which the router sends a complete copy of its routing table out to all neighbors.

Route invalid timer

Determines the length of time that must elapse (180 seconds) before a router determines that a route has become invalid. It will come to this conclusion if it hasn’t heard any updates about a particular route for that period. When that happens, the router will send out updates to all its neighbors letting them know that the route is invalid.

Holddown timer

This sets the amount of time during which routing information is suppressed. Routes will enter into the holddown state when an update packet is received that indicated the route is unreachable. This continues either until an update packet is received with a better metric or until the holddown timer expires. The default is 180 seconds.

Route flush timer

Sets the time between a route becoming invalid and its removal from the routing table (240 seconds). Before it's removed from the table, the router notifies its neighbors of that route's impending failure. The value of the route invalid timer must be less than that of the route flush timer. This gives the router enough time to tell its neighbors about the invalid route before the local routing table is updated.

Rip Routing configurations

We will use two router and four subnet. Create a topology as shown in figure on packet tracer.
basic rip routing
Router
FastEthernet 0/0
FastEthernet 0/1
Serial 0/0/0
R1
10.0.0.1
20.0.0.1
50.0.0.1
R2
30.0.0.1
40.0.0.1
50.0.0.2

PC
IP Address
PC
IP Address
PC0
20.0.0.2
PC1
20.0.0.3
PC2
40.0.0.2
PC3
40.0.0.3
PC4
10.0.0.2
PC5
10.0.0.3
PC6
30.0.0.2
PC7
30.0.0.3
Assign ip address to PC. Select pc and double click on it. select ip configurations from desktop tab and set ip address given as in table.
To configure router double click on it and select CLI.To configure this topology use this step by step guide.

(1841Router0) Hostname R1

To configure and enable rip routing on R1 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface fastethernet 0/1
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#exit
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 50.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#network 50.0.0.0

(2811Router1) Hostname R2

To configure and enable rip routing on R2 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,
 changed state to up
R2(config-if)#exit
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 40.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,
 changed state to up
R2(config-if)#exit
R2(config)#interface serial 0/0/0
R2(config-if)#ip address 50.0.0.2 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
R2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0,
 changed state to up
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 30.0.0.0
R2(config-router)#network 40.0.0.0
R2(config-router)#network 50.0.0.0
R2(config-router)#exit
To test rip routing do ping from pc0 to all pc and vice versa. If you get replay then you have successfully configured rip routing but if you did not get replay double check this configuration and try to troubleshoot. I have uploaded a configured and tested topology in case you are unable to locate the problem spot then download this configuration file. And try to find out where have you committed mistake

Basic Of Static Routing Configure Cisco Router


Static routing occurs when you manually add routes in each router's routing table. There are advantages and disadvantages to static routing, but that's true for all routing processes.
Static routing has the following advantages:
  • There is no overhead on the router CPU.
  • There is no bandwidth usage between routers.
  • It adds security because the administrator can choose to allow routing access to certain networks only.
Static routing has the following disadvantages:
  • The administrator must really understand the internetwork and how each router is connected in order to configure routes correctly.
  • If a network is added to the internetwork, the administrator has to add a route to it on all routers—manually.
  • It's not possible in large networks because maintaining it would be a full-time job in itself.
Command syntax for static route:
 
ip route [destination_network] [mask] [next-hop_address or
exit_interface] [administrative_distance] [permanent]  
ip route The command used to create the static route.
destination_network The network you're placing in the routing table.
mask The subnet mask being used on the network.
next-hop_address The address of the next-hop router that will receive the packet and forward it to the remote network.
exit_interfaceUsed in place of the next-hop address if you want, and shows up as a directly connected route.
administrative_distance By default, static routes have an administrative distance of 1 (or even 0 if you use an exit interface instead of a next-hop address).
permanent Keyword (Optional) Without the permanent keyword in a static route statement, a static route will be removed if an interface goes down. Adding the permanent keyword to a static route statement will keep the static routes in the routing table even if the interface goes down and the directly connected networks are removed.
In previous article you learn that
In this article we will recall all the topics you have learnt yet
and will try to implement these command in practically.
Create a topology as shown in figure on packet tracer or
download this topology.
basic router configurations
Now configure PC-0 first.To configure pc double click on pc and select desktop
Now click on IP configurations
configure ip
Set ip address as shown in figure
http://computernetworkingnotes.com/ccna_certifications/image/pkt_config_ip_pc1.jpg
 
IP address 10.0.0.2
Subnet mask 255.0.0.0
Default Gateway 10.0.0.1
Follow the same process in PC-2 and set the ip address to
 
IP address 30.0.0.2
Subnet mask 255.0.0.0
Default Gateway 30.0.0.1
Now double click on 1841 Router 0 and select CLI
router configurations
Type no and press enter to avoid startup configuration
Now you are in user exec mode.
                --- System Configuration Dialog ---
 
Continue with configuration dialog? [yes/no]: no
 
Press RETURN to get started!
 
Router>
Set Hostname to R1 and assign 10.0.0.1 255.0.0.0 ip address to fast Ethernet 0/0. also set a message “ Unauthorized access is prohibited”.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#banner motd # Unauthorized access is prohibited #
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#
Configure Router-2 in same way with hostname R2 and 30.0.0.1 255.0.0.0 ip address on fast Ethernet 0/0.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#exit
R2(config)#
Now we have connectivity between local segment and router's Ethernet port.

configure serial port

When Serial connections are configured they need one more command that normal Ethernet connections do not. That command is the clock rate command.
The clock rate command establishes a common rate at which the sending and receiving routers will send data to each other.
It should be noted that if using a service provider circuit, there is no need for the clock rate command since the service provider provides the clocking. Establish a simple serial to serial connection between R1 Serial 0/0/0 and R2 Serial 0/0/0.

Now configure serial port on both router with ip address 20.0.0.1 255.0.0.0 on one and 20.0.0.2 255.0.0.0 on two.

On R1

R1(config)#interface serial 0/0/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R1(config-if)#exit
R1(config)#

On R2

R2(config)#interface serial 0/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
At this point you have configured ip address on interfaces.
But still pc0 will not ping to pc1 as R1 have no information the network of 30.0.0.0

There are two way to configure route in router. Static or Dynamic. You will learn more about static and dynamic in our next article. In this example we will use simple static route.
First tell R1 about to network of 30.0.0.0
R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
R1(config)#
In this command 30.0.0.0 is the destination network and 255.0.0.0 is the subnetmask on destination network and 20.0.0.2 is the ip address of next hope
30.0.0.0 = destination network.
255.0.0.0 = subnet mask.
20.0.0.2 = next-hop address.
Say this way "To get to the destination network of 30.0.0.0, with a subnet mask of 255.0.0.0, send all packets to 20.0.0.2"
Now tell R2 about to network of 10.0.0.0
R2(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1
R2(config)#
Now test the connectivity. Go on pc1 and
C:\> ping 30.0.0.2
If you get reply then you have successfully configured static routing between R1 and R2.
But if you get error then download this
configured topology
and do cross check that where you have committed mistakes